· · · Новые сообщения · Участники · Правила форума · Поиск · RSS · · ·
Страница 1 из 11
Форум » Daemon Tools » Решение проблем в работе Daemon Tools » После удаления Daemon Tools остались виртуальные приводы
После удаления Daemon Tools остались виртуальные приводы
DEMBELДата: Вторник, 30.09.2008, 19:15 | Сообщение # 1
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
Описание: после удаления Daemon Tools остались нерабочие виртуальные приводы, в диспетчере устройств они могут быть помечены желтым значком, после неоднократной перезагрузки не исчезают. Произведено некорректное удаление Daemon Tools
Решение: читать
Дополнительно: + Поставить снова Daemon Tools и удалить оттуда, потом снова удалить Daemon Tools.
+ Зайти в Панель управления>Администрирование>Управление компьютером, затем в Запоминающие устройства>Управление дисками, выбрать диск который надо отключить, в контекстном меню выбрать "сменить букву или путь к диску", затем удалить.
 
Duremar100Дата: Четверг, 18.12.2008, 13:34 | Сообщение # 2
Новичок
Группа: Пользователи
Сообщений: 6
Репутация: 0
Статус: Offline
причина моей проблемы наверно наверно как раз в виртуальных приводах, установил версию daemon4302 lite, до этого предварительно удалив daemon pro, все прекрасно заработало, диски монтируются. но стоит только перезагрузить винд, при создании привода пишет ошибка драйвера daemon tools pro: -1. переустановил daemon4302 lite опять все отлично. и так каждый раз приходиться заново устанавливать. реестр чистил, делал все по пунктам. не помогает. может очередность автозапуска можно поменять. в диспетчере устройств на драйвере желтая иконка. и написано "Не удалось загрузить драйвер этого устройства, поскольку такое же устройство уже работает в системе".
 
DEMBELДата: Четверг, 18.12.2008, 17:15 | Сообщение # 3
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
по всей видимости у вас виста? Да, с выходом версии 4.30.2 ошибка -1 стала появляться чаще... Щас я соберусь с мыслями и запощу как от этого избавиться, а пока постарайтесь все вычистить от pro версии - файлы, реестр (воспользуйтесь поиском и найдите ветки "DT Soft" (2 штуки) а в них "Daemon Tools Pro", а также в других ветках посмотрите (автозапуск и прочие...). Удостоверьтесь, что sptd удален полностью и переустановите его.
Уточните, какое приложение выдает ошибку -1 DT pro или Lite, и от какой программы в диспетчере задач висит вирт. диск (это можно узнать сверив имена производителя вирт. устройства в дисп. устройств и в опциях программы)?
 
DEMBELДата: Четверг, 18.12.2008, 17:51 | Сообщение # 4
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
Блокируется загрузка драйвера виртуального диска - поэтому он у вас и висит, неопределенный. Попробуйте его удалить, он снова появляется?
Если у вас Vista SP1 32bit, то перезагрузитесь, в процессе загрузки нажмите F8 для отображения опций загрузки (там где "безопасный режим" и прочее), и в этих опциях выберите пункт "Disable driver signature enforcement" ("Отключить проверку цифровых подписей драйверов"). Драйвер виртуального диска не подписан microsoft поэтому возможно его загрузка блокируется... При установке отключите антивирусы и фаерволы, запретите их автозагрузку - они тоже могут блокировать драйвер.
А еще лучше снести весь Daemon Tools нафиг с драйверами и устройствами и переустановить...
 
Duremar100Дата: Четверг, 18.12.2008, 18:31 | Сообщение # 5
Новичок
Группа: Пользователи
Сообщений: 6
Репутация: 0
Статус: Offline
Quote (DEMBEL)
по всей видимости у вас виста?

нет, XP sp3
Quote (DEMBEL)
Удостоверьтесь, что sptd удален полностью

файл sptd удален полностью. в папке винд, систем32, драйверс. удалился легко, без безопасного режима. перезагружал винд, файла нету.
Quote (DEMBEL)
Уточните, какое приложение выдает ошибку -1 DT pro или Lite, и от какой программы в диспетчере задач висит вирт. диск (это можно узнать сверив имена производителя вирт. устройства в дисп. устройств и в опциях программы)?

pro я удалил полностью, весь реестр почистил. но при выборе количестве приводов в Lite, выдает эту ошибку tools pro: -1., видимо один из файлов драйвера у pro я не могу найти
проблема не критичная так как можно просто удалять и устанавливать программу, но не приятная. что-то во время загрузке винды видимо замещает один драйвер другим, или что-то вроде этого.
вирт. диска вообще нету. так как pro я удалил, а Lite после перезагрузке винды не дает мне создавать приводы.
зато один из контроллеров SCSI и Raid становиться желтым. опять таки после перзагрузке винды
Quote (DEMBEL)
Блокируется загрузка драйвера виртуального диска - поэтому он у вас и висит, неопределенный. Попробуйте его удалить, он снова появляется?

удалял я драйвер, не помогает. он появляется после установки заново Lite, но после перезагрузке компьютера становиться желтым.
Quote (DEMBEL)
А еще лучше снести весь Daemon Tools нафиг с драйверами и устройствами и переустановить...

пробовал. уже раз 10 сегодня компьютер перезагружал. качал и отдельно драйвер SPTDinst с сайта , удалял просто драйвер, удалял контроллер,
 
DEMBELДата: Четверг, 18.12.2008, 18:43 | Сообщение # 6
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
Quote (Duremar100)
зато один из контроллеров SCSI и Raid становиться желтым

вероятно именно этот контроллер остался от DT Pro (а с ним вероятно и один из виртуальных cd-dvd приводов), когда вы перезагружаете комп (видимо в dt lite у вас включены опции автозапуска и автомонтирования образов) образ пытается смонтироваться в устройство от DT Pro, а так как вы удалили его - пишет что ошибка драйвера. Проверьте еще раз все контроллеры и cd-dvd устройства на предмет принадлежности к DT Pro.
 
Duremar100Дата: Четверг, 18.12.2008, 18:59 | Сообщение # 7
Новичок
Группа: Пользователи
Сообщений: 6
Репутация: 0
Статус: Offline
DEMBEL,
контроллер я этот удалил, еще вместе с Pro, его не было. установив Lite, появляется контроллер, и он (не желтый) работает. все отлично. монтируются приводы. но стоит только перезагрузить компьютер. он вдруг желтый, вот такая вот...)
Quote (DEMBEL)
вас включены опции автозапуска и автомонтирования образов

нет, я не включал.

наверно банально реестр почистил плохо, что-то пропустил

 
DEMBELДата: Четверг, 18.12.2008, 19:02 | Сообщение # 8
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
Quote (Duremar100)
плохо, что-то пропустил

это уж точно
можешь сделать скриншот диспетчера устройств с раскрытыми ветками "cd-dvd дисководы" "scsi и raid контроллеры" и запостить?
 
Duremar100Дата: Четверг, 18.12.2008, 19:19 | Сообщение # 9
Новичок
Группа: Пользователи
Сообщений: 6
Репутация: 0
Статус: Offline
я могу легко перечислить что там.

DVD и CD-ROM дисководы
+ Optiarc DVD-RW AD-7200 SCSI CDRoom Device

SCSI и RAID контроллеры
+ JMicron JMB36X Controller
+ SCSI/RAID хост-контроллер (вот эта зараза, и есть желтая)

Не удалось загрузить драйвер этого устройства, поскольку такое же устройство уже работает в системе. (Код 42)

 
DEMBELДата: Четверг, 18.12.2008, 19:25 | Сообщение # 10
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
блин, так у тебя контроллер jmicron? вот этот еще может давать гемороище с вирт. приводами... щас у меня мысль созреет, мож еще что посоветую...
 
Duremar100Дата: Четверг, 18.12.2008, 19:30 | Сообщение # 11
Новичок
Группа: Пользователи
Сообщений: 6
Репутация: 0
Статус: Offline
ОК, спасибо)
сам попробую еще раз почистить реестр,
 
DEMBELДата: Четверг, 18.12.2008, 20:34 | Сообщение # 12
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
Хотелось бы взглянуть на твою ветку реестра:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}
Вот моя, обрати внимание на имена и значения параметров первого и четвертого ключа (ветки \0000, \0001... - порядковые номера устройств, у тебя могут отличаться), у тебя должны быть примерно такие же, и без всяких параметров типа UpperFilters и LowerFilters...
Что касается jmicron, то попробуй вместо него поставить стандартные системные драйвера Windows (что у тебя висит на этом контроллере кстати? hdd, cd-dvd привод?). Можно попытаться обновить дрова мат. платы (у тебя asus?). Если есть время, можно еще найти и выдрать из реестра ветки драйверов jmicron, тоже хотелось бы проверить...
Прикрепления: scsi_raid.txt(2Kb)
 
DEMBELДата: Четверг, 18.12.2008, 20:52 | Сообщение # 13
Вождь
Группа: Администраторы
Сообщений: 171
Репутация: 0
Статус: Offline
А вот инфа с сайта support.microsoft.com

Windows не может загрузить драйвер устройства для данного оборудования, поскольку дубликат устройства уже установлен в системе. (Код 42)

Рекомендуемое решение

Был обнаружен дубликат устройства. Эта ошибка происходит, когда драйвер шины некорректно создает два подпроцесса с одинаковыми названиями (ошибка драйвера шины) или когда устройство с серийным номером обнаружено в новом месте, прежде чем оно было удалено со старого места. Эту проблему можно решить, перезагрузив компьютер.

Сдается мне, что этот "дубликат" и есть SCSI-драйвер Jmicron.

Хотя может и неудаленный драйвер остался...

Quote (Duremar100)
+ SCSI/RAID хост-контроллер (вот эта зараза, и есть желтая)

Взгляни в свойствах что за драйвер, производитель?
 
Duremar100Дата: Пятница, 19.12.2008, 00:54 | Сообщение # 14
Новичок
Группа: Пользователи
Сообщений: 6
Репутация: 0
Статус: Offline
вроде все ок, вообщем все было намного легче чем я тут сгущал, почистил реестр от файла SPTD, единственное что пути были другие, немного не те что у вас /forum/6-11-1, вначале я побоялся столько реестра вырезать. а сейчас просто вбил в поиск по реестру SPTD, более 30 путей. думал винду щас угроблю. и удалил все. помогло, правда я пока один раз перезагрузку делал. ну прецедент создан) Вам большое спасибо, думаю тема "остались виртуальные приводы" раскрыта.

а Jmicron у меня с материнкой на диске был. он и с алкаголем и с pro, не конфликтовал. только вот для чего он нужен, я так и не понял

 
Форум » Daemon Tools » Решение проблем в работе Daemon Tools » После удаления Daemon Tools остались виртуальные приводы
Страница 1 из 11
Поиск:



лечение псориаза в израиле - смотрите описание у нас . ламинат unistep баня бассейн проект .